読者です 読者をやめる 読者になる 読者になる

gennei's blog

IT、読書、日記、メモ

LinkCheckerがインストールできるけども実行できない

ツールの調査のために「LinkChecker」を導入してみた。

参考にした記事 qiita.com

python 2.7.11 で実行

$ pip install LinkChecker  
$ linkchecker --help  
This program requires Python requests 2.2.0 or later.  

requests の version が古いようなので version を調べてみた。

$ pip list | grep requests  
$ requests (2.10.0)

あれ、全然新しいじゃないか。
uninstall と install を繰り返した結果、2.10 のバージョンを見た時にマイナーバージョンが1から始まっているのが問題なのではと予想。

$ pip install requests==2.9  
$ linkchecker --help  
...

正しく動いた。version check のロジックが間違っているみたいなので空いた時間で直したい。