読者です 読者をやめる 読者になる 読者になる

gennei's blog

IT、読書、日記、メモ

Update travis1.7.5 but doesn't run

travis を1.7.5にアップデートし、1.7.4を間違えて消してしまった。 その結果以下のエラーが発生し動かなくなってしまった。

console log

/Users/gennei/.rbenv/versions/2.2.0-rc1/lib/ruby/gems/2.2.0/gems/travis-1.7.5/lib/travis/cli/api_command.rb:150:in default_endpoint': undefined method[]' for nil:NilClass (NoMethodError) from /Users/gennei/.rbenv/versions/2.2.0-rc1/lib/ruby/gems/2.2.0/gems/travis-1.7.5/lib/travis/cli/api_command.rb:154:in detected_endpoint' from /Users/gennei/.rbenv/versions/2.2.0-rc1/lib/ruby/gems/2.2.0/gems/travis-1.7.5/lib/travis/cli/api_command.rb:70:indetected_endpoint?' from /Users/gennei/.rbenv/versions/2.2.0-rc1/lib/ruby/gems/2.2.0/gems/travis-1.7.5/lib/travis/cli/api_command.rb:158:in endpoint_option' from /Users/gennei/.rbenv/versions/2.2.0-rc1/lib/ruby/gems/2.2.0/gems/travis-1.7.5/lib/travis/cli/command.rb:213:inrescue in execute' from /Users/gennei/.rbenv/versions/2.2.0-rc1/lib/ruby/gems/2.2.0/gems/travis-1.7.5/lib/travis/cli/command.rb:191:in execute' from /Users/gennei/.rbenv/versions/2.2.0-rc1/lib/ruby/gems/2.2.0/gems/travis-1.7.5/lib/travis/cli.rb:64:inrun' from /Users/gennei/.rbenv/versions/2.2.0-rc1/lib/ruby/gems/2.2.0/gems/travis-1.7.5/bin/travis:18:in <top (required)>' from /Users/gennei/.rbenv/versions/2.2.0-rc1/bin/travis:23:inload' from /Users/gennei/.rbenv/versions/2.2.0-rc1/bin/travis:23:in `

'

困った(´・ω・`)